SYLLABUS PLUS:

PRINTING & REPORTING
Syllabus Plus

Printing & Reporting

This Syllabus Plus training guide covers printing and reporting data from Syllabus Plus (referred to as S+ throughout the manual). It assumes some knowledge of the system. If you have not used S+ before, please contact Programmes & Assessment (Timetabling) on ext. 34009. Topics covered in this manual are:

- Using templates to produce printouts;
- Exporting data to Excel;
- Editing templates and creating your own templates;
- Saving print templates.

If you have any questions when you have worked through the guide, please contact the Programmes & Assessment (Timetabling) team on ext. 34009 or timetable@leeds.ac.uk.

Contents

Section 1: Using Templates to Produce Printouts ................................................................. 3
  Individual Location Timetables .............................................................................. 4
  Master Location Timetables ............................................................................... 7
  Staff Timetables ................................................................................................. 9
  Module & Programme Timetables ...................................................................... 10
  Student Timetables ............................................................................................ 10
  Class Lists ......................................................................................................... 12
  Lists ..................................................................................................................... 13

Section 2: Exporting Data to Excel ............................................................................. 16

Section 3: Editing & Creating Your Own Templates .................................................... 17
  Editing Templates ................................................................................................ 17
  Creating Templates ........................................................................................... 25

Section 4: Saving Print Templates ............................................................................. 27
The printing and reporting functions in S+ are based around print templates, which are pre-defined layouts/views. When you retrieve an image from the Timetabling section of the SES website, the default print templates (i.e. those which are supplied with S+) will already be loaded. With the templates, you simply select the data that you want to print, run the report, and it will be formatted into a print-friendly layout for you.

Section 1: Using templates to produce printouts

When using templates to produce printouts from S+, there are two rules to follow to ensure success:

1. Select Print with the relevant window open – for example, if you are printing a staff timetable, you need to open the Staff window; if you are printing a module timetable, you need to open the Module window, etc.

2. Use Filter to select the records you want to print before selecting your template – for example, if you are printing room booking timetables for each room in your school, you can filter locations to show only your rooms, and print the timetables in bulk.

In this section of the guide, you will find step-by-step instructions for producing specific printouts. If there are any printouts that you would like to be able to produce that do not appear here, you can create your own templates, following the instructions in the Editing and Creating Templates section of this manual. If you are unable to create the template you need, contact the Programmes & Assessment (Timetabling) Team for advice on ext. 34009 or timetable@leeds.ac.uk.

In general, you should avoid relying on printed timetables wherever possible. Where they are used, please ensure that the recipients are aware that the information may swiftly become out of date.

Individual Location Timetables

If you wish to print a timetable showing bookings made in individual locations (for example, to display on the doors of school-owned rooms):

1. Select Locations from the Timetabler drop-down menu.

2. If you wish to print a single timetable for a specific room only, select the name of the room by clicking on it in the column on the left of the screen.
3. If you wish to generate printouts for each of your school-owned rooms, go to the **View** drop-down menu and select **Filter**.

4. Choose **Department** from the **Filter Locations by:** menu and select your school in the **Objects** box (shown below). Click **Filter**.

5. Holding down the **Ctrl key**, select the names of the rooms for which you require a timetable by clicking on them.
6. If you need to print timetables for all your locations, press Ctrl and A on your keyboard to select all the records.

7. From the File dropdown menu, select \textit{Print…} to open the \textit{Print Style} screen.

8. Select \textit{Individual} and \textit{Location Individual}, as shown above, and select the time periods, days and weeks you wish to print if required. In this example, we are printing the timetable of room bookings between 9am & 5pm (09:00 & 17:00), Monday to Friday in S+ week 10.

9. Click \textit{Preview}. If the resulting preview appears blank, but you know that bookings have been made, click \textit{Cancel} (bottom right corner), and then click \textit{Preview} again - the bookings should appear. This will open an \textit{Individual Print Locations} window.
10. Click the **Printer Setup…** button (circled above). This will open the **Print Setup** box.

11. Make sure the **Orientation** is set to **Landscape**, as above, and **click OK**.

12. Click **Print All** to send the timetables to the printer. If you have selected more than one room, then the timetable for each one will be printed on a separate page.
13. If you wish to view all the timetables before printing, use the drop-down menu (circled above) to look at each one in turn.

14. If you want to print the timetable you are viewing, rather than all the timetables you've selected, click **Print**… instead of **Print All**.

**Master Location Timetables**

The Master Location Timetable creates a print out with a page for each day of the week, showing only the locations where there are bookings. It is useful for gaining an overview of usage for the week.

1. Select **Locations** from the **Timetabler** drop-down menu.

2. To select all the rooms owned by your school, select **Filter** from the **View** drop-down menu. As described previously, select **Department** from the **Filter Locations By: list, and select your school in the **Objects** box. Click **Filter**.

3. Select all of your locations by clicking **Ctrl and A** on your keyboard.

4. Select **Print**… from the **File** drop-down menu.

5. Select **Master** and **Location Master** as shown below. Select the time periods, days and weeks to be printed as required. In this example, we are printing all bookings between 9:00 and 17:00, Monday to Friday, in S+ week 10. Click **Preview**.

**Please note:** It is advisable to select all locations to ensure that no bookings are missed from the master timetable. If a room does not have any bookings it will not appear on the printout.
6. Once the timetable is displayed, check the **Printer Setup** (as described previously in **Individual Location Timetables**) to ensure that the page orientation is set to **Landscape**.

7. Monday is displayed automatically. To view other days, click on the up and down arrows in the **page number box** (circled above).

8. Click **Print All** to print all the pages, or **Print...** to print only the page you are viewing.

**Please note:** if a location has a booking on any one day in the week, it will appear on each page of the printout.
**Staff Timetables**

As staff timetables are now available online, you are unlikely to need to provide members of staff with printed timetables from S+. Staff should be directed to the SES website where they will find, under the Staff Resources section, a page called Teaching Timetables which details how to access individual staff timetables online. However, if you do need to print out a staff timetable, you should make staff aware that, as is the case with all printouts, the timetable is likely to become out of date soon after being printed and that they will need to check for updates.

**Please note:** these timetables will only contain staff data if staff have been assigned to the activities they teach on S+.

1. Select **Staff** from the **Timetabler** drop-down menu.

2. Select the member(s) of staff whose timetable you need to print – do this by selecting them manually from the list on the left hand side of the window or *filter* by **Department** and press Ctrl and A on your keyboard to select all staff belonging to your school.

3. Select **Print...** from the **File** drop-down menu.

4. Select **Individual** and **Staff Individual**. Select time periods, days and weeks to be covered by the printout.

5. Click **Preview...**.
6. To view timetables for the other members of staff you’ve selected, use the drop down list (circled above).

7. Ensure that the page layout is set to Landscape using Printer Setup..., and then print the timetables using Print All, or Print... for a single timetable.

**Module & Programme Timetables**

Individual Module and Programme Timetables can be printed using the same method as described in the Staff Timetable section above.

**Student Timetables**

Personalised student timetables are available online. However, you may need to provide students with printed timetables in the event that they cannot gain access to the web. As with all printouts, you should make students aware that the timetable is likely to become out of date soon after being printed, and that they will need to check for updates.

*Please note:* student activities will only appear on these timetables if the student has been allocated to the activity in S+.

1. Select **Student Sets** from the **Timetabler** drop-down menu.
2. Select the students whose timetables you need to print – do this by selecting them manually from the list.

3. Select **Print...** from the **File** drop-down menu.

   ![Print Style](image)

4. Select **Individual** and **Student Set Individual** as shown above. Select time periods, days and weeks to be covered by the printout as required.

5. Click **Preview...**

   ![Preview](image)

6. To view timetables for other students you’ve selected, use the drop-down list (circled above). The student’s name and ID number will appear here, and also at the top of the page although in the example shown here the name has been blocked out.
Ensure that the page layout is set to *Landscape* using *Printer Setup…*, and then print the timetables using *Print All*, or *Print…* for a single timetable.

### Class Lists

The *Class List* template allows you to print a list of students linked to a particular activity. Although previously this template was distributed as a separate file which could be downloaded from the Timetabling web pages, it is now one of the default templates installed as standard.

1. Open an *Activities* window from the *Timetabler* drop-down menu.

2. In the list of activities on the left-hand side of the window, select the activity or activities for which you need a class list.

3. From the *File* drop-down menu select *Print…* to open the *Print Style* box.
4. Select **Text Spreadsheet** and **Class List** as shown above, and click **Preview**.

5. The students allocated to the activity will be listed in surname order, together with their student ID number. Click Print All to print the list.

**Lists**

Finally, S+ has a template called **Generic Object List** which is found under **Spreadsheet** in the **Print** window. This template produces a list containing the **Name** and **Description** of the information you have chosen. You may find this useful to:

- Print a list of modules;
- Print a list of scheduled or unscheduled activities;
- Print a list of all students enrolled on specific modules or programmes of study;
- Print a list of all students belonging to your school.

Before selecting **Print**, make sure that you have selected all the items of which you wish to print details. Do this, as with all printouts, by either manually selected them from the list on the left while holding down the **Ctrl** key, or by filtering to the information you want, and pressing **Ctrl** & **A** to select all.

The training guide will use an example of printing a list of unscheduled activities. The same technique can be used for other examples mentioned above.

1. Select **Activities** from the Timetabler drop-down menu.

2. Select **Filter** from the View drop-down menu.
3. As shown above, filter by Department, and select the name of your School from the Objects box. On the right (circled above) deselect Fully scheduled and Partially scheduled by un-ticking the boxes, leaving Unscheduled selected. Click Filter. You will then be viewing only unscheduled activities for your department.

Please note: this list also includes the Parent activities of Jointly Taught activities.
4. Select all by pressing Ctrl and A, then select Print... from the File drop-down menu.

5. Select Spreadsheet and Generic Object List, as shown above, and click Preview....

6. Click on Print All to print the list.

Please note: In Activities, you also have the option Activity List – this produces a list similar to that shown above, but containing more details about the activity, for example day/time, duration and location. You may prefer to use this.
Section 2: Exporting Data to Excel

1. If you need to create a spreadsheet rather than printing a list directly, click Cancel to exit the Print Preview. This will take you back to the Print Style box – click File...

![Image of Print Preview box with Text selected]

2. Select Text in the Select File Format box, as circled above.

3. Specify a name for the file, select the folder you wish to save it in and click Save.

![Image of Save Spreadsheet Printout to File]

4. The file will be saved as text format. To open this file, open Microsoft Excel.

5. Select File/Open and change the File Type box from All Microsoft Excel Files to Text Files.

6. Navigate to the folder where you saved the file.

7. Click on the filename to select it and click Open.

8. Once you have selected your file, Excel will take you through an Import Wizard. Simply click Next to accept all the defaults, and click Finish on the third screen. Your file will open as a spreadsheet. When you have done this, you may want to save it as a spreadsheet so that the file can be opened in future without needing the Import Wizard.
Please note: If you prefer to open files through Windows Explorer rather than opening Excel first, right-click on the file and select Open With, followed by Microsoft Excel. The file will then be opened automatically as a spreadsheet.

Section 3: Editing and creating your own templates

If the existing templates in S+ do not extract the information you require, you will need to either adapt an existing template, or create your own. The following examples focus on editing the Activity List, and creating your own Location List template, but the principles used can be applied for any kind of template.

Editing templates

To edit an activity list template:

1. Open an Activity window from the Timetabler drop-down menu.
2. Select an Activity from the list on the left of the screen.
3. Select Print… from the File drop-down menu to open the Print Style window.
4. Select the print template that you want to edit – for this example, select Spreadsheet and Activity List as shown below, followed by Preview…
5. Click the **Edit** button in the bottom left of the screen.

   ![Edit button](image1.png)

6. The **Edit** functions will appear on the right of the screen, as shown below:

   ![Edit functions](image2.png)

7. Change the name of the template in the box circled above to whatever you wish to call it and click **Create Template** directly beneath the box you have just amended. By doing this, you are editing your own version of the template rather than the original. The name of the template you have just created will appear in the list above.

8. There are three main areas of the report which can be edited – **the header, footer, and columns**. Right-click anywhere on the white area of the screen, and select **Header Editor...** to open the **Header Editor** box.
Please note: You will see that Show Accessors is selected (circled above). S+ uses the word Accessor to refer to the fields that you can choose to include in your report.

9. The Header will be repeated at the top of each page in your report. You can include text (referred to in S+ as String) or fields from S+ (Accessors).

10. To include text, click the New Line button, then select String on the left of your screen.

11. Type the text that you wish to include in the text box beneath the New Line button, then click Add and your text will be added to the header as shown below:

12. On the Header Editor, click Apply and then OK to apply the change.

13. The text you have entered will be displayed at the top of the page, as circled above.

14. You can also edit the footer – this determines what will be displayed at the bottom of each page. To do this, right-click on the main part (white area) of the page again, and select Footer Editor….
15. If you wish to add text to the bottom of the page, you can use the same method as the header: click **New Line, String**, type in your text and click **Add**.

16. You may also wish to add standard text at the bottom of the page. To view options for this, click **other** on the left of the screen (circled below).

17. To add an item, click the **New Line** button, then click the item you wish to use, and click **Add**. You may find it useful to include **Print Date** and **Print Time** in the footer – this is helpful in working out how recently a list has been printed, particularly during the compilation of the timetable when information frequently changes. These can be found in the **other** list as circled above.

18. You can use a combination of text and automatic fields.
19. In the example above, *Printed on*, *at* and *by* are all text strings, and `<Print Date>`, `<Print Time>` and `<User-Name>` are all selected from the other list. To combine elements in this way, click **New Line**, followed by **string**, then enter your first item (in this case, “Printed on”) in the text box and click **Add** twice:

![Footer Editor with example settings](image)

20. It will appear twice, as shown above. Click on the second item (circled above) and change the selection as shown below – your item will update accordingly.

![Footer Editor with updated settings](image)
21. Click **Add** to add a third item, edit as required – in this example, alternating between **strings** and **other** items, clicking **Add** in between. Continue until your footer is complete. Click **Apply** and **OK** when you have finished.

22. Finally, you will need to **edit** your columns. Right-click again and select **Column Editor**….

   The currently selected columns are shown on screen:

   ![Column Editor Screen](image)

23. Click on a column in the top section (circled above, containing the text Business School). The **S+** field (**accessor**) relating to this column is shown (circled above, just beneath the **Add** button).

24. This example will now work through three scenarios – **changing** the contents of a column, **removing** a column, and **adding** a new column.

25. We need to change the **Module ID** column to display the module name. Click in the **Module ID** column to select it.
26. The currently selected field (or accessor) – i.e. Module Host Key – is highlighted, as circled above. Click Activities, at the top of the list, to expand the options.

27. We need to change the column to display the Module Name – find Module in this list and click on it to expand the available options.

28. Select Name from this list (indicated above).
29. The contents of this column will update. Finally, you need to update the column header. Double-click on the text (Module ID in this example) and select other... from the list which appears.

30. Edit the text as required and press the Return key on your keyboard. You must press the Return key for the changes to be accepted. If you move to another column using the mouse, the column header will revert to its original value.

31. When you are happy with your changes, click on the Apply button and the template will be updated.

32. We also need to remove the Staff, Location, Weeks and Teaching Week Pattern columns from the template. Click on the Staff column, then click on the Remove button. Repeat for each of the other columns to be removed.

33. Click Apply to update the changes in the template.

34. Finally, we need to add a new column between the Size and Module Name columns.

35. Click on the Size column, and click Add. This will create a second Size column.

36. With this new, second column selected, click on Activities in the Accessor (or fields) box, and choose Scheduled: from the list that appears. The column will update accordingly.

37. Click Apply and OK to finish.
38. On the right of the screen, check that the correct template name is displayed, and click **Create Template** again to ensure your changes are saved.

**Please note:** These actions can be carried out to add or remove any columns from your report as required. When you have added all required columns to your report, remember to change the column heading by double-clicking on each one, selecting other... and entering the text you require. If the report you wish to create or edit is a timetable grid, this can also be done through S+ print templates. However, we recommend that you contact Programmes & Assessment (Timetabling) to discuss the best way to generate the report you require.

**Creating templates**

You may wish to create a new template if there is no existing template for you to adapt.

1. From the **Timetabler** menu, open the screen that you want to report on – for this example, select **Locations**.

2. Filter to the locations you need to include in your report by selecting **Filter** from the **View** drop-down menu. Either press **Ctrl and A** to select all locations in this list, or click on the locations you want to include, whilst pressing the **Ctrl** key to multiple select.

3. Select **Print...** from the **File** menu to open the **Print Style** window.

   ![Print Style Window](image)

4. Select **Spreadsheet** and **(none)** as circled above, and click **Preview...**
5. Click **Edit** (circled above).

6. Enter the name of your template in the box on the right of the screen (**Template name here**), as indicated above, and change the **Template Class** drop-down box to **Location**. If you are creating a report in another area of S+, **Template Class** should be changed to the name of record type, e.g. **Staff, Activity, Activity Template**, etc.) that you are creating the template for.

7. Click **Create Template**.
8. A **Name** column will appear in the report. You can then continue to add and edit columns, header, and footer as described in the previous section, *Editing Templates*.

9. When you have finished, click **Create Template** again to ensure that your changes have saved. Click **Print All** if you want to create a printout immediately.

**Section 4: Saving print templates**

If you create or change a print template in S+, it is advisable to save it outside your current image. This means that you will be able to use your template even if you need to retrieve a new image from the Programmes & Assessment (Timetabling) web pages.

1. From the **File** drop-down menu, select **Template Organiser**.
2. In the box on the left, select the name of the template you wish to save, and click the **Save As...** button (circled above).

3. Select **Save Selected** and click the **Save As...** button.

4. The Windows Save dialogue box will open. Choose a folder into which to save your template, type a filename into the **File name** box (circled below) and click **Save**. When typing a filename, simply replace the asterisk with the name. The file should always end with `.ptm`.

5. When you next need to use this print template, you can import it into S+ in addition to the default print templates which are already loaded in the image you retrieve from our website.
6. From the *File* drop-down menu, select **Template Organiser**. You will see that the default templates are already loaded.

7. Click on **Open**... (circled above), and navigate to where you have saved the print templates which you have created.

8. Select the name of the template(s) you wish to import in the list on the left, then click **Copy>>**. The template will then be added to the list on the right. You can then close the **Print Template Organiser** window.

9. It is recommended that you do not over-write the print templates provided with S+. If you have edited one of these templates, please save it using a different name.
This is the end of the manual. If you have any questions, please don’t hesitate to contact Programmes & Assessment (Timetabling) on ext. 34009 or, by email on timetable@leeds.ac.uk.